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Introduction

Overview

An Eclipse' project has been created to aid Eclipse users in getting started with the Voyager
examples. All examples without third-party dependencies outside of Java[l? are included in the
Eclipse build by default. Please follow this guide step-by-step.

Preface

The purpose of this guide is to get Eclipse users quickly started using Voyager. It assumes
knowledge of both Eclipse and Java.

This preface covers the following topics:

* Technical requirements
* Contacting technical support

Technical Requirements

Before following the steps of this guide, make sure that you have the following software
available on your computer:

e A Java Development Kit (JDK[J?), version 5 or higher.

* Eclipse 3.2 or higher.
Contacting Technical Support
Recursion Software welcomes your problem reports, and appreciates all comments and
suggestions for improving Voyager. Please send all feedback to the Recursion Software

Technical Support department.

Technical support for Voyager is available via the web, email, and phone. You can contact
Technical Support by sending email to psupport@recursionsw.com or by calling (972) 731-8800.

! Eclipse is a trademark of the Eclipse Foundation, Inc
? Java is a trademark of Sun Microsystems, Inc.
* IDK is a trademark of Sun Microsystems, Inc.
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Project set up

Setting Eclipse variables

Open $VOYAGER HOMES\examples\java\se-cdc\eclipse project as your workspace (e.g.,
C:\Program Files\RSI\Voyager\examples\java\se-cdc\eclipse project or

/opt/RSI/Voyager/examples/java/se-cdc/eclipse project).

Select Window->Preferences.

& Java - Eclipse Platform

File Edit Mavigate Search Project Run
E Hierarchy | —

S

o

: T
% Package Explor 52

Window EgElsl
Mew Window . - ~
Open Perspective 3
Show View »

Customize Perspective...
Save Perspective As...
Reset Perspective...
Close Perspective

Close All Perspectives

Mavigation 3

Preferences

% Problems 53 @ Javadoc @) Dedaration
0 items

Description

Resource

ﬁ|a’3ava |
= O || [E] TaskList 22
0 E-

(=% Uncategorized

EE Outline &3

An outline is not available.

Path

=g
=

b oAl b
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Select the General->Workspace->Linked Resources node. Make sure that “Enable linked
resources” is checked, and click on the button labeled “New...”

& Preferences

|Iink| | 5% | Linked Resources =T -
= (EHEL?L:IFS Enable linked resources
[=- Text Editors
Hyperlinking Path variablf__-s spe::iﬁ'_lumﬁnns in the file system. The locations of linked resources
Linked Mode may be spedfied relative to these path variables.
= Warkspace Defined path variables:
Linked Resources New. .
= Java =
= Editor Edit
Syntax Coloring -
@ oK l [ Cancel
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In the prompt window, enter vOYAGER HOME in the text field next to the “Name:” label and the
value of $voYAGER HOME% (the root of the Voyager install, for example, C:\Program
Files\RSI\Voyager) in the field next to the “Location:” label. Click the “OK” button on the

prompt window to confirm the change (do not close the Preferences window yet).

& New Variable

Define a New Path Variable

Enter a new variable name and its assocated location,

Name: | VOYAGER_HOME |
Location: | C:\Program Files\RSIWoyager| | [ File... ]

2] Ok H Cancel ]
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& Preferences

Jlink | G

[=)- General
[=- Editors
[=)- Text Editors
Hyperlinking
Linked Mode
= Waorkspace
Linked Resources
=l Java
[=- Editor
Syntax Coloring

Linked Resources

Enable linked resources

Path variables specify locations in the file system. The locations of linked resources

may be specified relative to these path variables.
Defined path variables:

[-=-VOYAGER_HOME - C:\Program Files\RSIWoyager

Edit...

Remaove

Ok

] [ Cancel

Copyright © 2007 - 2011 Recursion Software, Inc.

All Rights Reserved

Page 8 of 19



Repeat the above process for the classpath. Select the Java->Build Path->Classpath Variables
node. Click on the button labeled “New...”

& Preferences

|dasspath EM

[=- Ant
Runtime
= Java
[=- Build Path
Classpath Variable
< |

Classpath Variables

A dasspath variable can be added to a project's dass path. It can be used to define
the location of a JAR file that isn't part of the workspace. Mon modifiable dasspath
variables are setinternally (for example, JRE_LIB, JRE_SRC, and JRE_SRCROOT
depend on the JRE setting).

Defined dasspath variables:

FfRE_LIB (non modifiable, deprecated) - C:\Program Files\Java'jd
Eﬂ/JF‘.E_SF‘.C (non modifiable, deprecated) - C:\Program Files\Javalj
(74 JRE_SRCROQT {non modifiable, deprecated) - (empty) Edit
LZ?JUNIT_HDME (non modifiable, deprecated) - C:\deviedipse3.4'p .
[= JUNIT_SRC_HOME (non modifiable) - £%<cp entry ignore > ££

< | >

1" JRE_LIB is deprecated: Use the JRE System Library instead.

=

[ Ok l [ Cancel
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For the text field labeled “Name:” enter voyaGerR HOME. For the text field labeled “Path:” enter
the same value of $VOYAGER HOME$ entered above (e.g., C: \Program Files\RSI\Voyager).
Click the “OK” button on the prompt window to confirm the change and then click the “OK”
button on the Preferences window to exit Preferences.

& New Variable Entry

Name: | VOYAGER_HOME |

Path: | C:\Program Files\RSI\Woyager]| | [ File. .. ]

(£ oK H Cancel ]
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& Preferences

| dasspath “x | Classpath Variables A=) v
=- Ant ) A dasspath variable can be added to a project's dass path. It can be used to define
Runtime the location of a JAR file that isn't part of the workspace, Mon modifiable dasspath
= Java variables are set internally (for example, JRE_LIE, JRE_SR.C, and JRE_SRCROOT
=) Build Path depend on the JRE setting).

Classpath Variable | Defined dasspath variables:
Eﬁ’JRE_LIE {non modifiable, deprecated) - C:\Program Files\Java'jd| |
Eﬁ’JF{E_SF'.C (non modifiable, deprecated) - C:\Program Files\Javalj
TEJRE_SF'.CRDDT (non modifiable, deprecated) - (empty)

Edit...

[2£ JUNIT_HOME {non modifiable, deprecated) - C:\dev\edipse3.4\p
[ JUNIT_SRC_HOME (non modifiable) - ##<cp entry ignore =## =
[=-VOYAGER_HOME - C:\Program Files\RSIWoyager

[
| W

@ [ ()4 ] [ Cancel
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Importing the project

From the “File” menu, select “Import...”

& Java - Eclipse Platform

328 Edit Mavigate Search Project Run  Window Help

Mew Alt+Shift+n  # : - 7 . =
_ EH G @O * & | &’ Java |
COpen File. .. S —
=i = B || El TaskList 2 =8
= j 6@ = |5 =
Find:i [ | vl
£ Uncategorized
Convert Line Delimiters To 4
EE Outline &3 =0
Switch Workspace 4 @ -
Restart An outline is not available.
&5 Export...
Properties Alt+Enter
Exit
& Problems :7 @ Javadoc @; Dedaration & - — O
0 items
Description Resource Path Locat... | Type
=k
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Select the General -> Existing Projects into Workspace node and click the “Next > “ button.

Select
Create new projects from an archive file or directory. | g - 5 I

Select an import source:
|tg.-'|:-e filter text |

== General
@; Archive File
ﬁ Existing Projects into Warkspace
[, File System
EL Preferences
= cvs
= Run/Debug
[= Tasks
= Team
=R

Cancel
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Browse to the $VOYAGER HOME%\examples\java\lse-cdc\eclipse project directory (e.g.,
C:\Program Files\RSI\Voyager\examples\java\se-cdc\eclipse proj ect). You should
see VoyagerExamples in the “Projects:” list. Click the “Finish” button to import the project.

& Import |:|®

Import Projects
Select a directory to search for existing Edipse projects. / .
-
(%) Select root directory: | gram Files\RSIWoyager\examplesijava'se-cdd | [ Browse... ]
() select archive file: | |
Projects:

VoyagerExamples (c:\Program Files\RSIWoyageriexamples\java\se-cdc\edipse_projectivo Select Al

Deselect all

ik

Refresh

3

|

[ ]copy projects into workspace

':':’:' Mext Einish l [ Cancel

The examples project should build (examples with third-party dependencies such as messaging
are excluded by default).
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Running your first example

Predefined launch configurations for running Voyager are supplied with the Eclipse project.
Select the Run menu, then the “Run Configurations...” option.

& Java - Eclipse Platform

File Edit MNavigate Search Project JGULN Window Help

i 3& - Q- % %Run Ctrl+F11 #* ﬁwyhva |
%, Debug F11 = =
[% Packa 2 Yo Hierar | Z5. Navig B E] TaskList &2 8
Run History 3
B = = o =
H 5 Run As 3 I -
o] - ——
[= %= VoyagerExamples Run Configurations. .. Find: l:l » oAl ¢
B examples-src bug Hi R
=i JRE System Library [jdk1.5.1 Debug History . (54 Uncategorized
Bl Referenced Libraries Debug As ; )
(= launch_configs Debug Configurations...
5= outline 52 =0
=
An outline is not available.
", Skip All Breakpoints
Console % i rg- =08
Jg Add Java Exception Breakpoint. .. Ld
(® add Class Load Breakpoint...
Q) External Tools 4

Select the Java Application -> VoyagerOnPort8000 node and click “Run”.
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& Run Configurations

Create, manage, and run configurations
Run & Java application

w2 —Nv
E X B3

MName: | YoyagerOnPort3000

type filter text -
| {3 Main . 6J= Arguments | =, JRE 4}4} Classpath T:.'y Source E Environment | E=] Common
Java Applet )
— Project:
= Java Application
VoyagerOnPort7000 | VoyagerExamples | [ Browse...
L VoyagerOnPort3000 Main dlass:
VoyagerOnPort2000
Ju JUnit | com.recursionsw, ve, system.Main | [ Search...
Juj Task Context Test Indude system libraries when searching for a main dass
[ include inherited mains when searching for a main dass
[ 5top in main
Filter matched 7 of 8 items -

I

Close
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You should see that Voyager starts up successfully (you will see a message regarding a license
check failure until you add your 1icense.properties file to the classpath).

& Java - Eclipse Platform
File Edit Mavigate Search Project Run  Window Help

FZ" ﬁ'@'%'@&?@'@@ Qn'é. i . ﬁ|3yJava|
[# Pada 2 Yo Hierar | %5 Navig | = O = O || E TaskList &2 =0
2% ¢~ d@eE-e7
=] :pd VoyagerExamples X
Find: L
B examples-src l:l
B JRE System Library [jdk1.6.0_08] (£ Uncategorized

B Referenced Libraries
(= launch_configs

5= outline 52 =0

An outline is not available.

[£ Problems | @ Javadac @ Dedlaration | & Console &2 Ex 5ﬁ|@|@| = .9~ =0
oyagerOnPort8000 [Java Application] C:'\Program Files\Javatjdk1.6.0_06'bin'javaw.exe (Sep &, 2008 1:55:50 PM)
[thread: main; 9/8/08 1:55:54 PM CDT] Voyager startup: error loading license.properti

[thread: main; 9/8/08 1:55:54 PM CDT] WARNING: Voyager license key check failure, sta
[thread: Thread-3; 9/8/08 1:55:54 PM CDT] Warning: Voyager time-limited execution end
Warning: Voyager time-limited execution ends in 8 hours and 0 minutes

Voyager started.
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Now that Voyager is running on port 8000, you can run the Basics] example. To run the Basicsl
example, select examples.basics.Basicsl.java from the Package Explorer. Then, using the
right-click menu, select Run As -> Java Application.

& Java - Eclipse Platform
File Edit Source Refactor Mavigate Search Project Run  Window Help

F‘j' ﬁ'ﬁ'%'@&?@'gﬁ Qn'éz i % ﬁ|3§JJava|
[% Pada 2 Yo Hierar | %5 Navig | = O = O || B TaskList 22 =0
P =
B&| e~ Oo@ e~ @7
] .basi A~ )
=i examples.basics ~ Find: l:l yoal b
m r ,
AY] Basi New [£% Uncategorized
1) Basi Open F3
[J] Basi  openwith v
REA Open Type Hierarchy F4
B exampls oo Alt-+shift-+w v
2 example
1 example [ =) Copy Cirl+C
H} example B2 Copy Qualified Name 2= outline £2 =8
B example (& pagte Cirl4 -
2 example — &
2 example ¥ Delete Delete An outline is not available.
2 example
i example g4 path v
B eample o Alt+5hift+5 3
=
woi eample e Alt+Shift+T 3
2 example
1 example pug Import...
£ example &y Expart...
2 example
Refel 4 - ——— =
B exampls Terences Dedaration | B Conscle 52 A En 5ﬁ|@|@| jua ri- =08
1 example Dedarations 3 = 1=
B exampld ration] C:\Program Files\Java\jdk1.6.0_06%bin'javaw.exe (Sep 2, 2008 11:05:08 AM)
EE examsle Q:><h Refresh F5 8 11:05:12 AM CDT] Vovager startup: error loading license.propert
B example Assign Warking Sets... fense key check failure, starting in t,ir_.’.e—'_ir.’.it,ed eT.-'a'_':.at,i:j‘n: mode
2 11 -0FL=-173 TM _CIT ADMINC: Voyager license key check failure, st
EE example LR ing: Voyager time-limited execution en
i Debug As 4 ) 8 hours and 0 minutes
2 example " Run Configurations. ..
Validate
2 example
Team L4
2 example §
Compare With 4
1 example e With '
EE example Replace Wi .
B} example Restore from Local History. ..
B exampls Properties Alt+Enter
1 examplesmms —
< |3 |« >
:¢ examples.basics.Basics 1.java - VoyagerEdgeExamples/examples-src
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You should see the following output in the console window:
Started Voyager as a client

sun share price = 101

bought 10 shares of SUN for 1050
java.lang.IllegalArgumentException: share count < 0

& Java - Eclipse Platform
File Edit Mavigate Search Project Run  Window Help

- B0 Qr  BEO @O A 5 (@ ova |

[# Pada 2 Yo Hierar | %5 Navig | = O = O || B TaskList 22 =0
= g8 =E-|e7
=i examples.basics »~ )
= Find: L
m Basics1.java " l:l
4J) Basics2A.java (5% Uncategorized

m Basics 2B java
m BasicServer.java
README. TXT
2 examples,configuration
3 examples. configuration. hidden
2 examples, configuration, hidden
2 examples, connectionmgmt EE outline 52 =8
2 examples.corba.array
7} examples.corba.atiributes &
2 examples,corba.bank An outline is not available.
2 examples,corba. dient
4B examples.corba. comman
2 examples. corba.dynamic
1 examples.corba,enums
2 examples.corba. holder
1 examples,corba.javatoidl
£ examples.corba.module
3 examples.corba.naming
B examples.corba.narraw [£ Problems | @ Javadac @ Dedaration | B Conscle 52 b ¢ % EN Eﬁ|f—'|@'| fEB-ri-—H
g :i::s::::zz:z::s::;z::x <terminated > Basics 1 [Java Application] C:'\Program Files\Java'jdk1.6.0_06'bin'javaw.exe (Sep 2, 2008 11:05:39 AM)
H examples. corba.server |/ WARNING: Vovager license key check failure, starting in time-limited evaluation mode
EE examples.corba.structs Warning: Voyager t,irne—l:l:.mit,ed execution ends in & hours and 0 minutes
EE examples. corba. typecodes St,art,fad \’oyager as a client
7} examples,corba,unions sun ?snare p.I:LCE =101
bought 10 shares of SUN for 1050

8 examples.db 1 Illegald: tE £i £t <0
ava.lang. egaldrgumentException: share coun 0
2 examples.jmx 3 g g g i

2 examples.jsse

2 examples.managedagents
2 examples.message

1 examples.mobility

2 examples.naming

2 examples.rmi

|

Please refer to the user guide for more information on running other Voyager examples.
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